3

When I was entering an answer, to my own question, it put my answer as a comment instead. I tried it again, and the same thing happened again. I kept the two attempted answers -- that got strangely redirected as comments in there (decided to not delete them) as reference.

This is where I discovered it, see comment in question of post No Terminal in Unity after faild upgrade from Ubuntu 19.04 to 19.10

migrated from askubuntu.com Nov 1 at 12:53

This question came from our site for Ubuntu users and developers.

  • 1
    I don't understand what exactly your issue is. What comment are you referring to? Are you unable to post a self-answer to your question? But you did post an answer to the question you have linked. – pomsky Nov 1 at 6:19
  • Yes, I was finally able to, but only without the ending link in the post. Look at my original answer: askubuntu.com/posts/1185376/revisions Note that @WinEunuuchs2Unix edited the original answer. My original answer was short without the link at the end. Originally, when I was entering the answer it put my answer not as answer but bumped it to be a comment instead. That is the bug I want to report. I tried it again, and the same thing happened again. I kept the two attempted answers -- that got strangely redirected as comments in there (decided to not delete them) as reference. – MeSo2 Nov 1 at 15:47
5

That is not a bug, it is by design.

What is happening is you are posting a very short answer with a link and the system is picking that up automatically as a low quality / link only answer.

When you post a link answer you MUST include the relevant content from the link in the answer and leave the link as a reference.

To be fair to you, I had no idea this even a thing and it seems like it could be a poor way of handling these kinds of answers in some situations and we already have a review queue for this kind of thing.

You are welcome to take it here and request a change but I doubt it be well received.

Relevant topic link: Answer appears automatically converted as a comment

  • 2
    Ahhh.... Who knew? – WinEunuuchs2Unix Nov 1 at 17:27
  • 1
    @WinEunuuchs2Unix Not me, just Googled it when I saw this question. The post I linked is from 2011, so I'm amazed this hasn't come up before now and if this is a thing, why do so many link only answers reach review?. – Mark Kirby Nov 1 at 17:31
  • 1
    The other interesting thing is for the OP it appeared as a comment but for me it appeared as a one sentence answer with link which I edited with more details. – WinEunuuchs2Unix Nov 1 at 17:33
  • 1
    Correct. This happens for at least new users. I remember when I was new to the site, I added something as an answer but it automatically converted into comment. I guess this happens if the answerer/commentator themself is the questioner. – Kulfy Nov 1 at 17:33
  • @Kulfy "I guess this happens if the answerer/commentator themself is the questioner." Makes sense, I guess it is to stop information being added as an answer rather than to stop link onlys. – Mark Kirby Nov 1 at 17:35
2

If you find a bug in the Ask Ubuntu / StackExchange platform, you open a meta post here on https://meta.askubuntu.com and detail the specific issue you're seeing and use the 'bug' tag. This will draw attention to the issue for SE developers and staff to look at.

HOWEVER as it currently stands, you have not detailed the issue you're experiencing and don't detail steps to observe/reproduce the issue. We cannot help you (bugs or otherwise) if you don't provide details of the bug/issue you're running into on the SE platform, so we need a detailed explanation of what you're seeing, including screenshots where relevant, and you need to provide 'steps to reproduce' the problem so we can try and see what exactly you're seeing so we can reproduce the issue. If we (SE staff, elected moderators, others, etc.) can't reproduce the issue then the issue usually doesn't get identified or fixed/handled by the SE staff.

  • sorry had to change my vote - my question got reworded to the point that this other answer is more correct. (What a strange system we got going on?) – MeSo2 Nov 2 at 1:22
  • 1
    @MeSo2 Not strange, we took the information you left in comments and added it to your question so we could get to the real core problem. You are free to revert the edits made to it but IMO your real question was, why did this happen and what should I do, rather than just trying to report a bug. Again, if I am wrong, feel free to revert the edits, if not, you got an update for no effort :) – Mark Kirby Nov 2 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .