0

I have recently tried making an edit to my answer on this post, but, to my surprise, I get a message stating that "An error occurred submitting the edit."

An error occurred submitting the edit.

I suspected that it might be a temporary issue with Ask Ubuntu being in "read-only mode," as was the reason for the error in this post, so I waited several hours and tried again. However, the issue was not resolved after waiting.

I then suspected that it might be a problem with the content of the edit to the post, but I still get the error even when I make no changes at all to the post when editing.

I then suspected that it might be that I am unable to edit any answers, but I testing and was able to edit other answers I had made on Ask Ubuntu without any problems.

What else can I try? What could be the cause of the issue?

1

I don't see any signs that you've hit a blacklist or any of the spam-protection systems here.

It is possible you just got unlucky and tried to hit the site when things were down. Seems unlikely though.

Another area you might want to investigate is your ISP: it's possible they're doing some sort of content filtering (which is blocking the request before we see it) or simply have connection issues.

  • It indeed seems that my ISP was blocking posts that included the term chmod 777, or any valid chmod command for that matter. Switching to a connection through a cell phone hotspot, the problem was resolved immediately. How my ISP accomplished this is beyond me. Any ideas as to why this would be done, though? – fakedad Nov 7 '16 at 22:34
  • Why? You'd have to ask your ISP. My guess is, some vulnerability (for example, ShellShock) where attempts to exploit it involving a payload with that command, and rather than trying to block the vulnerability they just blocked requests with that (and probably other) probable payloads. – Shog9 Nov 7 '16 at 22:37
0

Evidently the problem was with the line that says "sudo chmod" and then "777 /media/iPhone/" For whatever reason, I cannot post that here, even when not formatted as code. Somehow, I managed to get it to work on the original post again, but I have no idea why it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .