5

Since the 27th May I've been unable to log in to cleanup.thepcspy.com with the Google OpenID that I was previously using, I keep getting a "500 Internal Server Error, Cherokee web server, Port 80" error.

Using Launchpad OpenID works fine as does Yahoo so no great problem, just thought I'd mention it, it may well be something I'm doing wrong! I've tried de-aunthenticating but get the same message when trying again, and different browsers make no difference either.

I noticed this page with people having similar problem with Google OpenID not sure if its relevant http://groups.google.com/group/google-appengine/browse_thread/thread/7107dead22a56879/b0d78a7e13ccf1e4

  • When you say "recently", when was the last time it worked for you? – Oli May 29 '12 at 10:42
  • Maybe Google servers were having issues? – ζ-- May 29 '12 at 12:14
  • @Oli I first noticed two days ago and haven't been able to log in with a Google OpenId since then, I use the URL google.com/accounts/o8/id – coversnail May 29 '12 at 13:37
  • Same here , I thought it was the problem with my network connection ,is there any alternative way to login to cleanup site? – Tachyons May 29 '12 at 15:48
2

I think I have fixed this.

A while ago I started moving Django sites to being hosted with uwsgi in a hope to move from Cherokee HTTPd to nginx. I got halfway through and stalled.

I only just had time to have a proper look at this last night and found that it was Cherokee throwing the error (instead of Django - as one might expect in this sorts of things). Turns out Cherokee isn't happy interacting with uwsgi in some cases so the only practical fix was to move the whole server to nginx (or backtrack, which I don't like to do).

Well I've just spent a couple of hours migrating dozens of sites over the nginx, including the clean up site and things seem to be working well, including with Google-based OpenIDs.

Let me know if this is a lie.

  • Working fine now, thank you! – coversnail Jun 16 '12 at 16:52
  • Now it says 502 Bad gateway – Tachyons Jun 23 '12 at 6:00
  • @tachyons Thanks for noticing that. I was trying to optimise my nginx/uwsgi configuration last night but obviously did it wrong. Give it another shot and let me know. – Oli Jun 23 '12 at 9:39
  • @oli Still getting a 502 Bad Gateway, but only with a Google OpenID, Launchpad one works – coversnail Jul 4 '12 at 12:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .