I am having this very strange pop-up ads issue when accessing any Stack Exchange site using Firefox. Whenever I click I get redirected to ads. I have done and tries the following:

  • cleared cookies, history, cache, etc.
  • disabled Firefox sync

but nothing works. I accessed Ask Ubuntu from Chrome and I didn't have that issue there. Now I did this based on this post:

  1. opened page source code for Ask Ubuntu, and I saw this:

    <body class="home-page new-topbar">
    <noscript><div id="noscript-padding"></div></noscript>
    <script>(function () { var old = $.fn.contents; $.fn.contents = function () { try { return old.apply(this, arguments); } catch (e) { return $([]); } } })()</script>
    <iframe id="adzerk-user-match" width="0" height="0" frameborder="0" scrolling="no" onload="window.AUMIframeDone=true"
        style="display: none;" marginheight="0" marginwidth="0"></iframe>
  2. But on Chrome, I see this with the same method as in 1:

    <body class="questions-page new-topbar">
    <noscript><div id="noscript-padding"></div></noscript>   
  3. Opened Ask Ubuntu in Firefox inspect tool and I saw this, just like in chrome:

    <body class="questions-page new-topbar">
    <noscript><div id="noscript-padding"></div></noscript> 

Now I don't know where that piece of injected code is coming from but its only seen when using Firefox. My problem here is that I get this issue only when on Stack Exchange sites.

How can I tackle this?

Now on the request i have added three images for ads that just popped up as I tried signing in to askubuntu from firefox with my adblocker app turned off just less than 2mins ago.

enter image description here

enter image description here

enter image description here

That's for three clicks I made on the site

  • You might have more luck with this on meta, the question is about askubuntu after all and as SE devs do go there, they have more chance to see it. I put in a vote to move it but it is really up to you.
    – Mark Kirby
    Commented Jan 2, 2017 at 17:33
  • Sure would be ok, as this issue is really annoying. Commented Jan 2, 2017 at 17:39
  • I sent it to review for moving but IDK if it will get moved from there any time soon. If you want it moved quickly, just custom flag it and a mod will do it.
    – Mark Kirby
    Commented Jan 2, 2017 at 18:16
  • Have you checked your installed extensions? Commented Jan 3, 2017 at 1:28
  • Yes I have removed all of them and even remove my bookmarks. Commented Jan 3, 2017 at 2:59
  • 1
    First glance, this is AdZerk, and is StackExchange's Ads system. (see this post here on "What criteria determines whether a Stack Exchange site should carry ads?"). Secondly, I'm not sure why it's showing an iFrame for you, but in Chrome if you look at the source for the page and search for "AdZerk" you get it inside of scripts, so it's importing some JS for the ads. Not sure this is malware though, may I ask why you think this?
    – Thomas Ward Mod
    Commented Jan 3, 2017 at 12:44
  • I believed it to be so because it kept bringing up pop-up windows and preventing me from using my firefox properly. Chrome seem to be able to control it, and also i noticed it only happened when I was on a stack exchange site. So I looked around on the web and suggestions were made as to this behaviour being characteristic of malware behaviour. For one it interrupts my visits to stack exchange. Is good I finally know where its coming from. Commented Jan 3, 2017 at 12:52
  • 2
    @George if it's bringing up popups, that's bad. I'll see if someone on the CM team is able to comment on this.
    – Thomas Ward Mod
    Commented Jan 3, 2017 at 12:53
  • Also that iframe if I am correct covers my whole page ensuring that where ever I click I get those pop-ups. Commented Jan 3, 2017 at 12:55
  • This doesn't sound like the sort of thing SE would allow. I'd suspect something injected between SE and the user. Have you tried disabling all/any extensions?
    – user403807
    Commented Jan 3, 2017 at 12:59
  • @ChrisF, I had to remove all my extensions, bookmarks, history, cookies, firefox sync etc you just name it. And I need these records for work but had to remove all as I didn't know what was causing this issue. Even scanned firefox folder to see if a malware was lurking there! Commented Jan 3, 2017 at 13:03
  • @George A screenshot of what you're specifically seeing might be useful here. Currently we're not able to tell if it's a whole-page ad, or if it's popup ads, or what. We also can't rule out ISP injection of ads either.
    – Thomas Ward Mod
    Commented Jan 3, 2017 at 13:03
  • That is odd. Especially as it behaves in Chrome.
    – user403807
    Commented Jan 3, 2017 at 13:04
  • @George (also for future reference, just moving your Firefox config folder out of your config data folder in your Linux home dir, or your appdata folder on Windows, will keep the rest of your stuff intact, and generate a fresh profile - this would help rule out malware too as I said in the chat pings I sent you)
    – Thomas Ward Mod
    Commented Jan 3, 2017 at 13:04
  • 1
    @George that's not what I was implying and I was imprecise in my wording. I meant the config data folder in your home dir config stuff, for Linux, or the appdata for WIndows (I can't tell what you use from here :P)
    – Thomas Ward Mod
    Commented Jan 3, 2017 at 13:08

1 Answer 1


Interesting. My default with issues like this is to assume that this is localized to you. Thus far, no one else seems to be experiencing the same issues, so I'm leaning pretty heavily in that direction. We do a lot to ensure the safety and security of our users, so I'm even more confident that this isn't our (my team's) fault.

But! The script you highlight, from Casale Media, is curious to me. Casale Media is Index Exchange, the company we use to manage our programmatic offerings. My assumption is that script is unrelated to your issue, and the fact that it appears only in Firefox is just the way the source code is displayed is different there versus Chrome.

As I state above: my current assumption is that this is an issue local to you. That said, I'm in the process of communicating with our contacts at both our ad server, Adzerk, and our programmatic partner, Index Exchange, to confirm that script is functioning as it should. I'll provide any relevant updates here.

Thank you for bringing this to our attention!

Update: our contact at Index Exchange confirmed that the script is only used for user-matching to ensure impressions are correctly delivered to who is targeted (ie: a user in France or a user visiting the tag). No content is delivered via this script. I hope this helps!

  • 1
    I decided to look into my /etc/hosts file as the word DNS kept cropping up in most of my findings. I discovered that my /etc/hosts file formatting was off with my local site names displaying on lines not preceded by with number So i reformatted and since then the pop-up ads have stopped. I will investigate further and confirm it's the cause. Commented Jan 4, 2017 at 9:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .