6

I've been meaning to post about this for a while. On my machine (LMDE, firefox, various versions) the letter i on AU is not displayed properly:

                                                                        an example of the bad i

You will need to zoom in a bit to see it clearly, but the i looks like this:

                                                                                a larger example of the bad i

This is surprisingly annoying and makes the text harder to read. For example:

enter image description here

Oddly enough, the letter is displayed correctly aligned if I increase the magnification of the page but it is off kilter at the default zoom level. It also looks OK on chrome, so it looks like a firefox-specific issue. It is also an AU-specific problem; I frequent quite a few SE sites and only have this issue here. I am guessing that this is because I am not using Ubuntu and this is some kind of Ubuntu-specific font but can this be fixed please?

  • Looks like a bug on your specific version of FF/Ubuntu. Not present on Chrome/Arch Linux (also using Ubuntu font, always have): imgur.com/EjeEq36 Do you have some script customizing AU? – muru Sep 23 '14 at 21:16
  • This also happened on my stock Firefox/Ubuntu 14.04. – Mateo Sep 23 '14 at 21:54
  • Not on Firefox/Arch Linux either: imgur.com/vRLNt9H – muru Sep 23 '14 at 22:12
  • @muru thanks for posting those images. Strange that you don't see it on FF. I'm not using Ubuntu, I'm on LMDE which is basically wheezy. Note that it looks fine for me too if I zoom in as it looks like you did for that screenshot. Can you confirm that it looks OK under FF even at the default zoom? – terdon Sep 24 '14 at 13:09
  • @terdon yep. I don't have the Arch system on hand, but on guest logins on a 12.04 and 14.04 system, Firefox (default zoom): imgur.com/6lL8PCl,qIsAzsv – muru Sep 24 '14 at 14:01
  • Yeah, works fine on my Ubuntu VM as well. It's been the case for as long as I've been using AU though so quite a few different versions of FF. – terdon Sep 24 '14 at 14:11
  • 1
    I can reproduce on FF 24.8.0 on gentoo. (oops, I guess that is Off-topic here, repro'd nonetheless) – casey Sep 24 '14 at 15:15
5

Turns out Mateo was spot on. The issue was fixed by adding this to my ~/.config/fontconfig/fonts.conf file (not ~/fonts.conf, when that file was created, running fc-list returned an error message telling me that I should switch to the one in ~/.config because ~/.fonts.conf is deprecated):

<match target="font">
    <edit mode="assign" name="autohint">
        <bool>true</bool>
    </edit>
</match>

My entire ~/.config/fontconfig/fonts.conf file is:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="autohint">
     <bool>true</bool>
  </edit>
</match>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintfull</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

I can now see the i with its dot in the right place. The dot was tiny however until I changed hintslight

4

Try this: https://askubuntu.com/a/362643/47291 , since it seems Firefox dosn't detect the system settings, Except for "hintstyle" use hintslight

enter image description here

I believe this happens because the "i" actually has a round dot on top, and the subpixel hinting is hinting on that edge while the other part of i falls where it doesn’t get hinting on that edge. Chrome might be respecting system settings or using different values for this.

  • hm, try different hinting. and by the way: now I'm going to blame it on Mint ;) because even with this change it displays the Ubuntu font wrong, for Ubuntu try changing settings in Unity tweak tool for the font, also what is your monitor resolution, that might have something to do with it – Mateo Sep 24 '14 at 14:52
  • Turns out that was the right way to go! I had a syntax error in my first try so I thought it didn't work. Since it would involve an extensive edit of your question and since there's no rep here, I posted my own answer. Thanks though! – terdon Sep 24 '14 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .