4

I took a 2 week vacation, back now, and when I went to log in on the desktop it no longer works in Firefox. It was working fine before, so something changed in the last 14 days. As my desktop computer was switched off, unused, it is most likely something with how the StackExchange login works.

When I click the 'Log in with StackExchange' in Firefox, the expected login fields no longer display:

login entry fields missing

Login with Chrome works fine, though it is not my preferred browser. Login with an Android mobile phone works fine as well.

The other four options (Google, Facebook, Yahoo & Launchpad) appear to work correctly, but as I have not associated them with my login account I cannot use them.

In Firefox, I use NoScript and have previously white-listed this domain plus stackauth.com, and stackexchange.com. Disabling the extension does not fix the issue. Third-party cookies are allowed.

It's probably something simple I'm missing, but how do I get StackExchange login working again in Firefox?

closed as too localized by fossfreedom Dec 5 '12 at 20:54

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • dumped your cache, cookies and other related stuff? – jrg Dec 3 '12 at 14:43
  • @jrg Yes, and now Chrome is also not working. Very strange. I can now only login with my mobile. Anyone else having issues? I have no clue how to fix this. – Tom Brossman Dec 3 '12 at 16:33
  • hm. i'm not sure what could be causing this. I'll send someone at SE, Inc a ping. – jrg Dec 3 '12 at 16:44
  • do you have adblock? Turn it off. also, might want to temporarily disable noscript (i know i know) entirely to see if that fixes it. – jrg Dec 3 '12 at 16:47
  • @jrg Temporarily disabling Adblock Plus fixed it immediately in Firefox, though this isn't a real solution. Is a fix being worked on? Removing the Adblock Plus extension is not an option. If I can provide more info or help diagnose the issue please ping or email me. – Tom Brossman Dec 3 '12 at 19:59
  • 1
    @TomBrossman meta.stackexchange.com/questions/156948/… – jrg Dec 3 '12 at 21:27
  • This can be closed as a duplicate of the Meta SO post. They are identical and the answers there fix the problem. – Tom Brossman Dec 4 '12 at 9:13

Browse other questions tagged .