6

I have the following tags:

  • kde
  • kubuntu
  • kwin
  • plasma
  • plasma-5

Today I discovered that tagged questions have the following css:

.tagged-interesting {
    box-shadow: inset 0 1px 0 
    rgba(255,255,255,0.25);
}


.tagged-interesting {
    background-color: 
    #fffbec;
}

But the css seems to be applied only when two tags are present.

Questions highlighted only when two tags are present

In the image above, questions 1, 2, and 4 have two of my tags and are highlighted. Questions 3 and 5 have only one of my tags and aren't highlighted.

I would expect the css to be applied even when one tag is present.


I've checked with Firefox 71 (with Stylus inactivated & uBlock origin active) Google Chrome 78.0.3904.108 (no extensions) and Falkon 3.0.0 (internal ad blocker disabled and no other extensions active).

| |
  • It seems to work fine for me watching and unwatching the tags on the questions page. Could it be related to something on your end eg browser choice, add ons or scripts you have running? – Mark Kirby Dec 7 '19 at 13:37
  • @MarkKirby So you see questions highlighted when only one of your tags is present? I've checked with Firefox (with Stylus inactivated & uBlock origin active) and with Google Chrome (no extensions). Both browsers are their current versions. – DK Bose Dec 7 '19 at 13:40
  • Yes, I unfollowed all tags and then tried following just one tag and the highlight worked. I also tried following two tags on one question and another with just one followed tag and both questions were highlighted. I have Firefox too and only Ublock is added.Here I followed 14.04, ssh and rsync and both questions get highlighted: imgur.com/a/yP7ElOH – Mark Kirby Dec 7 '19 at 13:49
  • Thanks for the feedback! Can't argue with that. Now to figure out why I'm not seeing what you see. – DK Bose Dec 7 '19 at 13:56
  • 1
    I tried to recreate your exact situation, followed the tags you list and the searched [kubuntu] and I do get the same result as you and as far as I can tell it is because the tag kubuntu was searched for and that tag alone on a question is not highlighted, I guess because all results have it, only the other tags are. So it seems to be related to the search term, same thing happens to any tag I follow and then search for. – Mark Kirby Dec 7 '19 at 13:57
  • I just tried your route: Untagged my existing choices, then chose 14.04 and Firefox as tags (with Falkon). I see the highlight only when both tags are present. So basically my problem persists. – DK Bose Dec 7 '19 at 14:02
  • Actually, I want to see questions with my tags highlighted when I view "Newest" or "Active" questions, not when I search via the tags themselves. I'll add that to the question. – DK Bose Dec 7 '19 at 14:05
6

I misunderstood how highlighting works. It works as expected if I view "Newest" questions or "Active" questions. I was mistakenly searching through tagged questions. In the image, you can see that the search criterion was "[Kubuntu]" and so questions 3 and 5 with just "Kubuntu" as the tag weren't being highlighted.

(By the way, I hadn't noticed the highlighting until today when I happened to change the angle of my laptop screen. It's a bit too subtle for me.)

| |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .