My question is triggered by this question, which has some close votes due to being off-topic, and a comment saying that it is unsupported.

14.04 appears to be the most recently supported distribution with PHP5 available in the repositories. A question about 14.04 would clearly be off-topic at this stage.

But the linked question asks about installing old software on a still supported release (18.04). How should we handle this? At some point, the answer will probably be not possible, due to changes in libraries and so forth. One quick example is QT4-applications.

So when do we stop accepting such questions? Should we stop accepting them? Should we close them, or should we answer not trivially achievable when it's a huge work?

5 Answers 5


We have a rule that we don't support Ubuntu versions that are no longer supported by Canonical. However, there is no rule about software from other sources. And I really think there shouldn't be such a rule.

First of all, many tools simply don't have newer versions. So you have no choice but to try and use an older one. And yes, while some of those might have security issues, the vast majority won't. For instance, domain-specific tools or minor github projects that haven't been updated. These aren't big important things like Java engines, but minor, simple tools that do a particular thing and which haven't been updated.

Not all projects are regularly updated and, more importantly, not all environments can safely use up to date software. There are often very valid reasons foe using specific versions of a tool, even if that version is old. Not only is it often the case that there simply isn't a newer version, but other times, you need that older version to make sure that your system works as expected. You may have updated the operating system on a production machine, for example, but cannot update the software tools you are using because doing so will change the results that your server gives to clients.

So yes, we should absolutely support older versions of software. If they can work on newer Ubuntu versions, then we can post answers with the necessary workarounds. If they cannot work on the newer versions of Ubuntu, then we post an answer saying it's impossible. But in no case should we have a rule that we will only support the latest version of a program!

  • "Not only is it often the case that there simply isn't a newer version, but other times, you need that older version to make sure that your system works as expected. " Exactly. And there's also costs; it's very easy for us to say "upgrade your software or upgrade your system" but in actual production environment it means costs in real money for upgrading large number of machines or rewriting code which can be essentially from scratch. So using older versions of software/kernel often is the only option Commented Jul 15, 2019 at 16:36

In my honest opinion we should still support questions specific to currently supported release but asking for a software that ain't supported anymore. For example, Java 9 and 10 have reached their end of public support (Reference: Java version history - Wikipedia). But still we got a question about installing Java 9 on June 23, 2019. Some people indeed love older versions and want to continue with it as long as they can. But again they should be specific to currently supported release. Also, they can be answered if the answerer is brave enough to satisfy the dependencies without breaking the system. An answer like this ain't possible is acceptable, I guess, but you can also give reference to a newer version/alternative too and its installation process.

  • 2
    I somewhat agree, but running old software is dangerous, and possibly not understood by the asker. Which is a dilemma...
    – vidarlo
    Commented Jul 12, 2019 at 11:08
  • 5
    @vidarlo Leave a note for them in that case :)
    – Kulfy
    Commented Jul 12, 2019 at 11:09

Do we stop supporting external software?

No do not stop, with commentary.

The problem with old versions is that they clutter and confuse searches and explanations for current users of current software.

I'm of the opinion that asking questions for old things should be allowed, but only if they are specifically identified as such. I think truly solving the above problem is done at the underlying website/engine level in the same way that someone could search for help, but prioritize newer responses. I have personally found great value in finding old solutions to awkward partly-related old questions for my current-software-problems. The fact that those questions have been posed recently or not is irrelevant to my value of them.

"supporting external software" creates the problem of distracting the attention of answerers. They ought to pay more attention to current software for the larger audience and for the explicit purpose of this site.

Explicitly support: If more reasonably implemented (better identification/search), even though the above answerer-distraction problem remains.

Explicitly do not support: If it clutters and could obviously threaten the purpose of this site.

Since no change at the engine level is proposed/forthcoming, I think some form of do nothing makes sense.

Do nothing, discourage feels right to me. That is, allow it to become a cultural norm for people to ignore these problems or not spend very much time helping, and to let the questioner know why. Bounties then remain a possibility to those questioners.


I don't know much about these platforms, and so I beg your pardon if what I write seems naive, but I do recognize the need for support for older versions. I use them myself on older HW, and I would really like to have dedicated areas specialized on old versions (and, too, dedicated repositories for them, with older versions of OS as well as SW versions).

So wouldn't it be fine to have either a new section or a new platform for these, and optionally a way to move questions there, accordingly? This way, they wouldn't "clutter" this platform, but nevertheless, satisfy the needs of those who have new questions about old versions.

This way, whenever a question appears that obviously concerns an older version, it can be moved to the dedicated "legacy" area and doesn't disturb anymore.

Perhaps something similar already exists and I don't know about it? In this case, I'd be grateful for the relevant information.

  • 1
    As terdon mentioned in their answer (and judging by the answer's score, it is an opinion that has the community's support), we do support old software installed on Ubuntu. But not old and no longer supported releases of Ubuntu. For those kind of questions, you can still ask them on Unix & Linux which is another site that is also part of the Stack Exchange network.
    – Dan
    Commented Jul 17, 2019 at 15:17
  • And thanks for the edit. ;-) Commented Jul 17, 2019 at 16:59

The bottom-line from me is: do the installation/usage instructions provided by the software's publisher still apply to the version of Ubuntu that the user is running, or does using the software require shenanigans such as installing packages from other versions of Ubuntu or doing ugly things with symlinks or LD_PRELOAD?

The Java question goes into the first category, as probably does installing PHP 5.3, so even though I would not answer such questions myself I wouldn't VTC either.

The second category I am more uneasy with. While I can sympathise to some extent with the user who really, really needs to run software which was not compiled/packaged in a way that is compatible with his or her version of Ubuntu (e.g., software that is distributed as a DEB with a dependency on libpng12-0 when the user is running 18.04+), I just think that dealing with this should be the software's publisher's job, not ours, because we are not every software publisher's user support helpdesk.

Although I have in the past advised people about installing packages from other Ubuntu, I don't do it anymore and now in the above case I answer "This package is not compatible with 18.04; you can use 16.04 or ask the package's publisher for a 18.04-compatible version," which I now believe is the only proper answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .