17

The software centre image is often used when explaining how to install software, like this (I fixed this one on the original page):


In Ubuntu 11.10 it is now possible to change the edge reveal time out using compiz-config-settings-manager Install compiz-config-settings-manager http://bit.ly/software-small.


As you can see, the image link is broken.

The bitly link for the software centre is broken:

http://bit.ly/software-small

It points to

http://i.imgur.com/oRhB2.png

instead of

http://i.stack.imgur.com/oRhB2.png

I don't know much about bitly, but it looks like it was posted by marcoceppi. If he's out there, can he change it? Otherwise, all instances need to be changed.

Or, if we had a template for apt packages, that would be a good replacement.

Screenshot


wget https://bitly.com/software-small
--2011-10-20 01:55:03--  https://bitly.com/software-small
Resolving bitly.com... 69.58.188.33, 69.58.188.34
Connecting to bitly.com|69.58.188.33|:443... connected.
HTTP request sent, awaiting response... 301 Moved
Location: http://i.imgur.com/oRhB2.png [following]
--2011-10-20 01:55:04--  http://i.imgur.com/oRhB2.png
Resolving i.imgur.com... 93.184.221.133
Connecting to i.imgur.com|93.184.221.133|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2011-10-20 01:55:04 ERROR 404: Not Found.
  • Hmm -- I had chalked this one up to the content filtering at my work, but it looks more widespread than I realized. For me, works from home, not from work. – belacqua Oct 20 '11 at 18:51
  • Related: Change the Software Icon – Marco Ceppi Oct 24 '11 at 20:09
  • 1
    Still broken as of today, can we do anything to troubleshoot or help? I voted in the linked post above. – Tom Brossman Nov 12 '11 at 15:34
9

A hotfix has been created, going forward the following urls should be utilized:

http://hostmar.co/software-small
http://hostmar.co/software-large

They will always map to the appropriate Software Center icon.


Stack Exchange is aware of this and a fix is in the works with no ETA at this time.


This appears to be an issue with certain ISPs, while the root cause is unknown, it appears to affect a large part of the community. As a result I've updated the bit.ly link to point to a different URL of the same image.

enter image description here


The image links isn't broken.

enter image description here

enter image description here

Not sure how else to replicate this. The image isn't hosted on the Stack Exchange imgur account - it's hosted in my personal imgur account. Furthermore you can not change a bit.ly URL map once it's been created. So even if it wasn't working I still wouldn't be able to update the shortcut. Rechecked, you can't edit the link.

  • 4
    I have the same problem as pydave, I've added a screenshot to his original post. Could it be working for you because you're logged in or something? – 8128 Oct 3 '11 at 20:26
  • @fluteflute Even in incognito, it shows up. – Marco Ceppi Oct 3 '11 at 23:37
  • Do we need a custom URL redirect for this image? (By that I mean should we be using a special URL within our control that we can redirect to whatever image we need?) – Nathan Osman Oct 4 '11 at 17:53
  • 1
    The image is reported as “no longer available” for me at home as well. It works from a different ISP in the same country. – Gilles Oct 10 '11 at 22:10
  • I will get in touch with Stack Exchange to see if they can community with imgur about the issue. – Marco Ceppi Oct 10 '11 at 23:03
  • I am getting the same issue, Marco. Every so often it doesn't load up. Can whoever owns the bit.ly links change the URLs so they are i.stack.imgur.com instead of just i.imgur.com – Oli Oct 11 '11 at 13:57
  • From where I am right now, i.imgur.com/oRhB2.png gives me “no longer available”, and I'm not the only one. Could you try changing to an i.stack.imgur.com image? – Gilles Oct 20 '11 at 14:58
  • @Gilles No, You can not change the link in bit.ly. – Marco Ceppi Oct 20 '11 at 15:00
  • @MarcoCeppi Wait, I'm confused. That's what you said earlier, then you struck it out and said you'd updated the bit.ly link. – Gilles Oct 20 '11 at 16:13
  • @Gilles I was mistaken and corrected later on. You can change the links TITLE, not the actual link though. – Marco Ceppi Oct 20 '11 at 16:16
  • Oh. It's annoying that this often-used image is broken for many visitors. Have you contacted Imgur? Do you think we should ask the SE devs for a mass-edit to a different link? – Gilles Oct 20 '11 at 16:51
  • @Gilles I'll be speaking with SE today about it - see what options are availalble – Marco Ceppi Oct 20 '11 at 16:51
  • @MarcoCeppi Any progress on this? The images are still broken. – Lekensteyn Nov 22 '11 at 16:07
  • I should note that this doesn't only happen to software center images. It also affects certain screenshots, as well. – Scott Severance Dec 11 '11 at 21:24
  • @ScottSeverance The screenshots are a different issue, can you please open a new meta post about those when you come across them? There should be an easy fix for those. – Marco Ceppi Dec 12 '11 at 3:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .