2

I have added link to apps.ubuntu.com by providing a button to click on till now...

But neither by the method -

"[package name] (link)" and nor by assign a url to the button image,i could give a direct link to start the software center.

I have found out by inspecting the javascript og other sites and apps.ubuntu.com that the url that the button leads to is

apt://packagename

but when i use it,

in the "[package name] (link)" method the link is not created at all and

in the button method the button does not remain a button an becomes just a simple image.

and neither is my answer accepted if i put just apt://packagename as the link behind the button.

It says invalid url or something..

How do i get it working.??The Button one specially...

  • Isn't this a regular Ask Ubuntu question rather than a question for meta? – Chan-Ho Suh May 19 '12 at 13:12
  • 1
    Its about providing links etc ON ask-ubuntu...on ask-ubuntu we ask ubuntu related questions and on meta we ask ask-ubuntu related questions rite?? – Nirmik May 19 '12 at 13:17
  • link and image with the scrips posted in this answer – user47206 Apr 30 '13 at 13:26
1

URIs on the internet go like this:

<scheme name>://<hierarchical path>?<query>

(eg) http://askubuntu.com/questions?sort=newest

There are dozens of URI scheme names in use; the most popular are http and https, but irc, geo, git, and apt are some examples of alternatives.

As far as I know, Stack Exchange (our Q&A engine) only allows http and https URIs. As such, your apt:// URLS will not be accepted in posts. This is unlikely to change. Ask Ubuntu community consensus recommends linking to packages for installation like this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .