8

On 16.04 with Firefox, whenever I try to go to askubuntu.com, I'm redirected to google.com ! This is true if I type the address in the url or if I click on the askubuntu logo on this site.

Notice that going to a specific question works...

Is there an ongoing problem on the site, or is the problem on my side ?

[EDIT] So, this is a firefox specific problem, as things work fine in Ubuntu Browser. I tried a new profile (firefox -P) and things work here too. So this is a profile specific problem. I've tried to find the core cause, and after googling a bit, I found this question https://superuser.com/questions/467999/clear-301-redirect-cache-in-firefox

So I cleared askubuntu.com history (forget about this site) and the redirection is gone... I still don't know how it first came, but now I know about the http 301 answer :-)

migrated from askubuntu.com Oct 12 '16 at 13:06

This question came from our site for Ubuntu users and developers.

  • 7
    I think it's just you, try starting a new firefox profile (type firefox -p in a terminal and select new profile to launch) and see if the problem persists. BTW, I think this is a meta question. – Zanna Oct 11 '16 at 7:55
  • 3
    Problem on your side or with your ISP. Change your settings to use your own DNS server like google's public dns or opendns – Sergiy Kolodyazhnyy Oct 11 '16 at 7:58
  • I tried with Ubuntu Web Browser, and things work fine. So dns is ok, it's really related to my Firefox settings... maybe a plugin ? I'm investiging it further... – alci Oct 11 '16 at 8:24
  • 1
    Please add your solution as an answer. – Android Dev Oct 12 '16 at 15:35
8

I solved this issue with the following steps:

  1. determine if the problem is Firefox specific: I tried with Ubuntu Web Browser, and everything was fine, so it is Firefox specific (so there no dns problem for example)

  2. determine if the problem is Profile specific: I tried with a new profile (using firefox -P to create a test profile), and it worked, so it is profile specific

  3. then I found this question https://superuser.com/questions/467999/clear-301-redirect-cache-in-firefox I learned about HTTP 301 permanent redirect

I finally cleared the cache for the askubuntu.com url, which fixed the problem:

  • open the history panel in Firefox (Ctrl + H)
  • search for askubuntu.com
  • right-click on the entry, and choose 'forget this site'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .