7

This is not the same bug of 'appstreamcli' that causes high CPU usage and cause update to hang, which was already raised in this old meta post asked by Braiam in mid-2016.

Different 'appstreamcli' error

The recently posted duplicate questions about 'appstreamcli' error is being shown when running sudo apt-get update command and the ends with "Aborted (core dumped)" and "E: ..." lines.

I have personally encountered this issue earlier today, as below.

$ sudo apt-get update
[sudo] password for xxxxx: 
Hit:1 http://mirror.netspace.net.au/pub/ubuntu xenial InRelease
Hit:2 http://mirror.netspace.net.au/pub/ubuntu xenial-updates InRelease
Hit:3 http://mirror.netspace.net.au/pub/ubuntu xenial-security InRelease
*** Error in `appstreamcli': double free or corruption (fasttop): 0x0000000002fc0c70 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7f8b3f3287e5]
...
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
Aborted (core dumped)
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi'
E: Sub-process returned an error code

Searching on Ask Ubuntu with keywords "is:question error in appstreamcli" returns 15 results at this time of posting. Of those 15 results, I have briefly checked all and have confirmed that there are 6 questions that have the same issue as described above.

From newest to oldest:

  1. Cannot update software, asked 2 hours ago by Calixte, 0 votes 0 answers

  2. After automatic upgrade, apt-get update cause Error inappstreamcli': double free or corru…, asked 3 hours ago by kaorukobo, 0 votes 1 answer

  3. Library corruption error during apt-get update, asked yesterday by Shirley Temple, 0 votes 1 answer

  4. E: Problem executing scripts APT::Update::Post-Invoke-Success, asked Aug 4 by subrat, 0 votes 2 answers

  5. Ubuntu 16.04: Enable wifi giving error while get-update, asked Mar 19 by Nidhi Mehta, 0 votes 1 answer

  6. Segmentation Fault while updating repositories, asked Oct 15 '16 by Thecave3, 0 votes 1 answer

The oldest question is dated back in 2016, but remaining 5 questions have been posted by different users, especially since last week. All questions but one mentioned 16.04 release.

There is one problem

Now that I am aware of the duplicates, I could not decide for one thing:

Which one of the 6 relevant questions that should be treated as "master" question so that remaining questions could be marked as duplicate of the "master" question?

Once this is cleared up, anyone could be redirected to the "master" question and upvote the question and answer that was helpful.

How would the community on AU resolve this case?

5

Here (I think) is the very minimal new Launchpad bug report for this issue.

IMHO, because it has upvotes and upvoted answers, Library corruption error during apt-get update is looking like the master post - After automatic upgrade, apt-get update cause `Error in `appstreamcli': double free or corruption` is already closed against it.

However, I think the answers need expansion - at least someone should add to the answers or post a new answer with a link to the bug report and advise people affected to add themselves to affected users on the bug report. The current workaround is apparently to remove the package. What are the consequences of doing so? Presumably people will want to reinstall it when a fix is released. No answer anywhere covers this properly, it seems to me.

This post is quite old: Ubuntu 16.04: appstreamcli error while get-update. The fix posted there by Yaron is from May 2016, and suggests installing version 0.9.4-1 which I think was the "fixed" upstream version at the time, but the current, broken package is seemingly 0.10.6-2 so this is a substantial downgrade and may not be the best idea. A new user who posted the same link as an answer to E: Problem executing scripts APT::Update::Post-Invoke-Success said it "worked for me" although when is unclear and the long-term consequences of downgrading are to be discovered... Nonetheless, merging the latter post with the master may be beneficial if we can improve the answers to inform users fully about what they are doing.

For now I have voted to close Cannot update software due to appstreamcli error and Segmentation Fault while updating repositories (although it is an old post and probably relates to an older, fixed bug and on second thoughts should probably be closed as no-repro) and E: Problem executing scripts APT::Update::Post-Invoke-Success against Library corruption error during apt-get update.

I hope someone with better knowledge will be able to improve the master post. I will check back later and if no one has I will try to do some further research and fix it myself, but I am sure others could do a better job.

  • 1
    Thanks for the follow up. I agree that Library corruption error during apt-get update is good choice for "master" question and the most upvoted answer has worked for me too. So I guess the meta question is now solved. Accepting this meta answer. – clearkimura Aug 11 '17 at 7:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .