1

This question already has an answer here:

All links in the HTTPS Ask Ubuntu, except for the navbar, are HTTP. Even if I specifically open https://askubuntu.com, navigating anywhere returns me to HTTP. Neither do I want it, nor it is an expected behavior for HTTPS site. And since it's supported why is HTTP even active anyway? Everything should be redirected to HTTPS by default.

marked as duplicate by Mark Kirby, edwinksl, Byte Commander, muru, Kaz Wolfe Sep 30 '16 at 18:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5

Solution

If you need HTTPS to protect your privacy on all pages of Ask Ubuntu, install the HTTPS Everywhere browser extension and it will modify all requests by replacing http: with https:.

Explanation

This is a weakness of Stack Exchange and should be corrected. They might need to invest money on better hardware and in software engineering to support the huge number of TLS 1.2 connections, otherwise some visitors may experience timeout or certificate errors.

HTTPS Everywhere has a special rule for Ask Ubuntu and you will not have connection problems. Your browser will show a green lock, click on it to see: 128 bit TLS 1.2 encryption from DigiCert Inc..

Suggestion

If you use Mozilla Firefox (or Iceweasel) and the privacy is a huge priority of your LAN, visit about:config from your address bar and search for the option security.tls.version.min. Insert a higher number to prevent some HTTPS degradation attacks.

Not the answer you're looking for? Browse other questions tagged .