I took a specialist interest in answering this question because I similar difficulties which I resolved and wanted to help a fellow member with it. I answered the question, however, the member still had difficulties (but I stayed with it).

I sent a final comment suggesting to try something new. The bottom line is they answered their own question with more or less what I suggested in my comment and accepted their answer.

If he/she had of answered my comment instead, I would have gladly modified my answer which may have benefited others in the future. As it stands the question is tagged with 64bit and he/she installed the 32bit package (my answer catered for both versions).

  • 2
    Was their answer actually the same as your comment? If I understand correctly, your comment suggested to remove the package and all its dependencies. The OP's answer, to do a "complete purge," means that an operation equivalent to apt-get purge (or some other removal with with --purge flag) was performed. That is, to "completely remove" a package in Synaptic is to remove it and delete all its systemwide configuration files, not to remove it and its dependencies. Commented May 14, 2012 at 15:19
  • I agree with your comments, the method I suggested was different but the principle was the same (Purge and reinstall). At the end of the day the questionner wanted to successfully run Google Earth 64bit on their machine and settled for 32bit. How to purge something in Ubuntu is a matter of familiarity with the coding or in my case Synaptic PM. Commented May 14, 2012 at 16:20
  • I was trying to be helpful, and without suggesting that the questioner was messing around with a broken package. It was beyond my expertize to help him fix the package which is why I suggested what I did. I guess gripe wasnt about the final solution, nor am I reputation hungry. I visit this site to be helped myself and I am quite willing to give help when I can. I have had hassle free computing since I converted from Windows to Ubuntu, I owe the community that much. Commented May 14, 2012 at 16:21
  • 2
    Your comment said to use Synaptic to uninstall the package and all its dependencies. Unless the OP used the term "complete purge" incorrectly in his/her answer, this is probably not what s/he did. With the title and tone of this meta question, you're accusing that OP of acting unethically. Given these facts, that really doesn't seem fair. It seems to me that whether or not the OP's own answer was substantially similar to your answer is pretty subjective. Commented May 18, 2012 at 13:54
  • @mateo_salta, Why is this confusing, please explain? This library is a requirement (fact) even for 64bit. I stated this clearly at the bottom of my answer. Sometimes you know things and do research and don't know remember the source. I keep notes on my own installation and this was in my notes. I didnt note down WHY? but when I saw the question it was something I was able to answer with certainty and I wanted to help. If needed, update the answer with a caution stating your confusion and anyone using the method i described should do some research why before implementing it. Commented May 19, 2012 at 21:05
  • Is this the source? guptamayank.com/how-to/install-google-earth-on-ubuntu-10.10
    – Mateo
    Commented May 20, 2012 at 1:43
  • Ive never used this source, so I can say with clarity No (I have a 12.04 platform) I think you have 3 options (since you find the answer confusing) 1: Down-vote the answer, 2: Flag it for moderators attention stating the answer is not helpful or 3 Vote it for deletion. As previously stated, this method worked for me and I thought it was a plausible answer that would help others. If you have noticed sometime that is not technically correct please advise me or at the vary least the moderators. Its the only way we can clean the answer up. Commented May 20, 2012 at 1:57

2 Answers 2


There's nothing we can really do about this behavior. Except correct it by voting. I went ahead and upvoted you (for putting the work in) and downvoted him (for providing a less than stellar answer). He also made his answer a Community Wiki, why he did this I'm not certain of, but he's not collecting any reputation for that answer in the end. In the short term it sucks to have something like this happen, and luckily it's a corner case on Ask Ubuntu to see this kind of behavior. In the long term your question will far outshine his despite it being the accepted answer as it will logically sort your answer to the top (since it's the highest voted)

  • 2
    It's disappointing to see such a rush to judgment, especially in a public forum, from a respected community member. I've generally seen encouragement on answering one's one question if none of the other answers are satisfactory. Now I guess I will think twice. Not only can I be publicly accused of unethical behavior (I'm baffled that some people use such strong language for this kind of small matter), but community pillars will not carefully examine evidence before stating I have "this kind of behavior". Commented May 19, 2012 at 11:15
  • It's clear, based on the timestamps and comments, that Stephen's answer was what ultimately lead to the fix to the question. Not only that, but the accepted answer isn't very helpful and is out of context. We encourage users to answer their own questions but we also hope they don't trample other users efforts in an attempt to secure their answer as the right one. Commented May 20, 2012 at 13:30
  • It just seems like a typical nooby behavior. Nobody denies Stephen's effort contributed (the OP thanks everyone, including presumably him). The actual solution is substantially different. If we had to accept everyone's answer which "ultimately" led to the final solution, then I see a lot of "unethical" behavior! Commented May 20, 2012 at 20:04

Actually, Stephen, the person did respond to your last comment on your answer. S/he said your suggestion didn't work. Then s/he apparently tried something different (and yes, whether one removes configuration files or not is a big difference, I don't see how you can suggest otherwise), and it worked.

  • Thanks, this was my mistake (lesson learnt) I didnt see the little "+" link for more comments at the bottom of my screen. Commented May 20, 2012 at 2:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .