10

I don't know if this is the right place to ask this, but I haven't seen it answered anywhere. More than a year ago, I was asking Ask Ubuntu about having a desktop shortcut to Google Calendar on Ubuntu 20.04. I received a few answers, but I was unable to get them to work. I confessed my ignorance of computer use and got some more suggestions, which I still couldn't implement, so I gave up.

Then a few days ago, I got a new answer:

You can use Calendar Indicator instead.

To download it type these lines in terminal: ...

When I tried to install the downloaded app, Google blocked it, saying it is unsafe. When I clicked on the Calendar Indicator pop-up's Privacy link, the site could not be found. I'm now wondering if I've been sent to a dangerous download, or is it just Google wanting to control everything? Is there anything Ask Ubuntu can do to keep malicious links out? If a bad link is posted, will someone notice it and send an alert?

7
  • 1
    You should read: Are PPAs safe...
    – Nmath
    Jul 22 at 22:48
  • I will say that this particular project has a GitHub repository with the source code available (which I've linked into the answer), but we can only assume that the source is the same as what is installed from the PPA. Also, it's not a very popular project with only 21 stars (which is still 13 more than mine has, for whatever that's worth). But the biggest indicator of issues is likely that it hasn't had any commits (other than the readme) in 3 years, so it doesn't feel "actively maintained." Jul 23 at 2:48
  • A little late (my apologies) but I have placed a 7 day lock on the original AU answer while this is all being sorted...
    – andrew.46 Mod
    Jul 25 at 7:55
  • 2
    I tried the app in a VM and sure enough the message is: Couldn't sign you in This browser or app may not be secure. Try using a different browser. If you’re already using a supported browser, you can try again to sign in. Doubtless you have 2FA in your Google settings? Which means you cannot now allow what Google considers 'insecure' apps and looks like Calendar Indicator is one of those apps. You are not alone as I see many 'me too' additions to this bug report: github.com/atareao/calendar-indicator/issues/7 as well as several other bug reports with exactly the same issue...
    – andrew.46 Mod
    Jul 25 at 8:22
  • @andrew.46 Sounds like the answer might just need a comment (at the least) or perhaps an edit to mention that it probably won't work work with 2FA (with a link to those issues)? Jul 25 at 19:28
  • @NotTheDr01ds I see the lock has expired now so if you feel like doing the needful?
    – andrew.46 Mod
    Aug 1 at 10:48
  • @andrew.46 Done - Thanks. Aug 1 at 14:15

3 Answers 3

12

Ask Ubuntu is moderated by community members just like you.

Our users and elected moderators do our best to keep malicious content off of the site. If you see malicious content, you should flag.

Questions and answers also come from community members. Not all answers are good answers. An answer doesn't have to be outright malicious for it to cause harm. If you follow bad advice from sources that are not knowledgeable or authoritative, you can create problems. Similarly, if you follow advice that doesn't apply to your situation, or if you don't apply solutions faithfully, you can cause problems.

If you see a bad answer, you can comment with an explanation why it's bad. You can also vote down.

In the end, you are ultimately responsible for what you download and execute on your system. You need to exercise just as much caution here as you would anywhere else.

I strongly recommend that you don't blindly run commands or perform actions when you don't know what they do. Yes, those actions could be malicious; but more likely, you'll have problems because you really have no idea what you just did or how to reverse it. If you don't know what something does, then research it until you do.

4

I see that @Nmath and @NotTheDr01ds have beautifully addressed the more global issues raised in this question. I have nothing extra to add to their excellent comments so I will just add a few thoughts about the answer itself that triggered the more general questions.

I ran the commands listed in the answer in a 20.04 VM and all went smoothly until I attempted to connect to Google, and then I saw the same warning that @Frank P spoke of:

enter image description here

Now I note in your post here on Meta you stated:

When I tried to install the downloaded app, Google blocked it, saying it is unsafe.

Not completely correct as Google has stated that your browser or app as not being unsafe but instead that it 'may not be secure'. I suspect that Calendar-Indicator has not adapted to changes at the Google end which relate to security standards for apps that use their service. My own experience of these changes over the years (as a mutt and Gmail user) has been:

  1. Early days: A comparative free-for-all where most applications could easily access Google services
  2. Changing days: Most so-called 'non-secure' apps could access Google services if 'Allow access by less secure apps' was checked in Google security settings
  3. Modern days: 2 Factor Authentication (2FA) is being rolled out and for applications that do not understand 2FA an App Password can be generated and successfully used. 'Allow access by less secure apps' no longer available when 2FA is used.

Somewhere in these changes it seems that Calendar-Indicator has lost its ability to access Google. There have been 3 bugs filed on this with the developer:

Unfortunately the developer has not yet responded to any of these bug reports.

In conclusion:

So for this specific answer, as has been suggested, the solution is to leave a reference to this Meta question and answer in the comments (or perhaps merely reference in the comments the unresolved bugs on the developer's bug tracker). And then vote down, in this way the Community has registered its opinions. All of this after the lock on the answer has expired, this will allow time for any further discussion on issues raised by the question or answers on this Meta thread.

And thanks for bringing the issue to Meta!

2
  • And sometimes app passwords still don't work. Try accessing your Gmail via POP3 from SeaMonkey's mail client. And good luck with their tech support. Script readers on the other side of the Earth, seemingly.
    – Zeiss Ikon
    Jul 27 at 11:27
  • @ZeissIkon Google's Gmail can be very, very frustrating at times...
    – andrew.46 Mod
    Jul 29 at 5:15
3

I fully agree with @Nmath's answer, but I'd add that you should take two actions to help the community yourself:

  • First, comment on the answer that Google flagged the app as "Unsafe" and blocked its use against Google Calendar. People reading this later need to be aware of that so that they either (a) don't install it, or (b) at least know that it didn't work for you.

  • Second, downvote the answer -- It didn't work for you. It wasn't helpful, and based on what you've said, it's likely not to work for others. If the person who posted it can come back and give additional guidance, then you can always reverse the downvote (and even accept it, if it ultimately works). Currently there's one downvote (mine) and one upvote (probably, if I had to take a guess, based on @ChanganAuto and my edits that make the answer look better than it might be).

As @Nmath said, we as a community are the ones who moderate it, and you're part of that community. Please make sure to do your part to help others by taking action on that answer based on your experience!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .