1

So I read a comment, it seemed good, so I "upvoted" it (with the teeny-weeny little triangle).

Then in like 15 seconds I spotted that somehow I skipped over an important detail that actually makes me disagree with the comment and I don't want to suggest any more that it represents a valuable position.

I immediately moved for the triangle again, but clicking it did not help, however fast I have caught the mistake.

Please consider how comments are so much less legible than regular content: this is a significant catalyst for this kind of mistake.


Edit:

From Muru I have learned that it is allowed within a minute's timeframe.

enter image description here

I have tried it out now and it worked.

Could the time limit to revoke an "upvote" on a comment be raised to a reasonable value, one that corresponds on how long someone may spend until entirely parsed a comment thread's information? Or even, to one that allows for one to update their position (change their mind) due to information found in another answer to the same question? (That would make like at least 5-10 minutes.)


I should mention that I have just found an AU website bug that destroys (or rather, fails to restore) the comment vote revoking mechanism entirely (click interactions on the upvoted triangle are dead) if one navigates away and then returns to the page (or reloads), even within the time limit.

(If navigating back to the page happens with the browser's history back button, a reload will be necessary, because the page otherwise does not show the results of the latest interactions. For example the fact that I upvoted the comment becomes visible again only after a page reload. Which however does not restore the revoking mechanism.)


Update:

Yeah, you can close this with won't fix. I have found the site-wide bug-report where they answered that they won't do anything to it: Unable to undo comment-upvote after page reload

New update:

I have left comments on the (in my opinion, misguided) official answer that (in an arrogant tone) rejects any improvements, but they got deleted. (I have already seen enough around the meta SE to not be shocked, or even surprised by this.)

So I at least bring my comments here. If any of you see a way to get this seen by those who could improve things (I must say, in general), please help with it.

StackOverflow is running the very platform where the developers of current and future digital infrastructure gather to learn their craft from. This puts an incredibly big responsibility on this company / website to lead by good example. If you personally have a doubt about this being a bug, an overlooked detail (or at least a lazy implementation, a shortcut taken) — that now you appear to excuse retroacively (explaining it with policy and "intent") — then please consult a coding expert who can clarify it for you.

"intentionally unforgiving"? — in terms of user experience, this is terrible, and I can't fathom how SO would ever need to rely on intentionally terrible experience. For the sake of humankind — tumbling forward ever faster into a digitally lived society of ever growing impact — I ask you to connect the dots and see the biblical amount of misery and suffering that would get unleashed on people in all walks of life if developers worldwide would take example from this kind of attitude. I wish that you can grow up to the responsibility, and manage to lead by good example.

11
  • 3
    I was able to reproduce this bug - it's not showing the box to ask to remove the upvote. Chrome Version 89.0.4389.90 (Official Build) (64-bit). This is already a 'feature' in the system, but the box asking you to confirm is not showing up for some reason. Removing feature-request from tags, but leaving support and bug – Thomas Ward Apr 5 at 13:34
  • @ThomasWard I don't think that's a bug. Any number of sites based on live-updating via JavaScript are all bugged in the same way, so I think this is just how JS-based actions don't trigger (or whatever the term is) when page state is restored by the browser for the back button. – muru Apr 5 at 13:50
  • @muru Except I replicated this on a fresh profile on the page without the Back button or anything else. Thereby rendering the statement you just made void, AND on an unrelated question/post. – Thomas Ward Apr 5 at 13:53
  • @ThomasWard Details for reproducing? Browser, etc.? – muru Apr 5 at 13:56
  • 1
    @muru same procedure as OP, upvote a comment, attempt to retract vote. Read my comment for browser details. (Forgive the crassness, side-effects of COVID vaccine and general tiredness are not a good combo.) – Thomas Ward Apr 5 at 13:57
  • @muru what you are describing is the de-generation, the de-evolution of websites. Websites, whose creators focus more on the shininess of their frameworks than on what they implement with them. The definition of what is usable for human visitors of a website does not depend on what technology one used for implementing that website. And the way it's losing functionality on page reload can be fixed: it just needs more work: another parameter supplied by the server in the markup, and one or two additional javascript methods to re-attach the event-listener and reinvoke the corresponding UI part. – Levente Apr 5 at 14:00
  • 1
    @muru All it needs is the right mindset: paying attention to details like this, willingness to carry out the steps it needs to function, and not to put up with the sorry trend that goes "others are lazy about it too, guess that's how we will have to live from now on". – Levente Apr 5 at 14:07
  • @Thomas yep, reproduced, also on Firefox desktop and Android too. – muru Apr 5 at 14:11
  • Since the issue is reproducible, would it be okay to edit the post to make it a full-on bug report something like Cannot retract upvote on a comment after reloading the page? As for extending the timer, maybe that should be a separate feature request. The whole "retracting votes on a comment" was implemented only as a feature request to remove "accidental upvotes" as opposed to "changing one's mind". – Dan Apr 6 at 8:58
  • @Dan I agree and consent. Except for please make the primary term "Navigating away" instead of reloading. And please leave the part in place that explains how a reload is necessary after navigating back. – Levente Apr 6 at 8:59
  • This question is closable without further action: see my latest update. – Levente Apr 6 at 16:26

You must log in to answer this question.

Browse other questions tagged .