I run into this problem often. Case in point:

19.10 seems to have broken suspend on my MB Pro

This user has a reputation of 111, appears to be an active contributor, and actually has the same problem I came here looking for answer to, along with possibly 84 other people, who have viewed his question. It's incredibly unhelpful.


The reason for the close is given in the yellow box under the question

"Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues."

Bugs are explicitly off topic here, as per the help, meaning this is not a "valid" question.

You state "It's incredibly unhelpful" but it is quite the opposite. Firstly the question had no answer, so won't be helping you or anyone else find a solution but the reason for closing gives the link to the correct place to report the bug and that is very helpful, seriously, go and report it on Launchpad, the developers will see it and they are the ones who can fix the issue, the more of you that go and report a bug, the more priority the devs will give to it and the quicker it will be fixed.

  • So, here's the thing... It wasn't a bug, it was a mis-configuration. How do I know? Because I had the same problem and I fixed it myself. The solution: edit /etc/gdm3/custom.conf to include the line: WaylandEnable=false This detail matters because the author of the original question states he has an Nvidia GPU, which is broken with Wayland and is what is causing the sleep issue. Too bad nobody will see this because it was down-voted and a comment that is wrong was up-voted. I guess "it's a bug" has been decided... – David Shepard Nov 10 at 19:56
  • 3
    @DavidShepard I've commented on the question with a link to your comment here. That should help keep your solution from falling into obscurity before a longer-term way to provide the information is found. That could be by reopening the question if people think it's not a bug, or by linking to a bug report where your solution is mentioned as a workaround. I recommend you edit your meta question to add what you said in your comment--if possible, in somewhat more detail, as the OP didn't say he had an Nvidia GPU, and I don't think every MacBook Pro has one. (Perhaps all of them from 2010 did?) – Eliah Kagan Nov 11 at 1:31
  • thank you both @DavidShepard and @EliahKagan. I think my issue is that I had no way of knowing that it's a bug before I posted the question. I have managed to work around it by using the proprietary Nvidia drivers, but they come with a bunch of different issues (glitchy weirdness at the bottom of the screen). Unfortunately, your WaylandEnabled=false fix doesn't appear to have worked for me. – MalphasWats Nov 16 at 10:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .