3

Other Stack Exchange sites have a common login. Once logged into one site, one is also logged into the other sites that one has activated.

Ask-Ubuntu shares user profiles with these other Stack Exchange sites, yet the log-in remains independent. Why is that?

  • 3
    It isn't independent. It works just like any other SE site. Can you describe what happens in your case? – terdon Jun 17 at 12:12
  • 1
    Might you be blocking cookies or do you have any other kind of privacy add-on in your browser that could prevent the login from working properly? – Byte Commander Jun 17 at 12:19
  • @terdon, I close the browser and start it new. I open stackOverflow, and I am still logged in. I open askUbuntu, and I am logged out. – bogl Jun 17 at 12:20
  • And if you log into AU, then close the browser and open it again? – terdon Jun 17 at 12:23
  • 1
    @ByteCommander Yes, plenty! :) I checked them, and from that point no surprise, "Cookie AutoDelete" was the problem. I had already a whitelist entry for *.stackexchange.com. AskUbuntu needed another entry because of the different domain name. – bogl Jun 17 at 12:29
  • @bogl Nice that you found the culprit. Would you mind writing what you said in the comment above as an answer, so that you can mark the question as solved by accepting it? – Byte Commander Jun 17 at 12:47
4

The StackExchange network depends on browser cookies to remember the login state. Most StackExchange sites use *.stackexchange.com as domain, AskUbuntu is one of many exceptions using its own 2nd level domain (askubuntu.com).

The use of different privacy tools becomes more and more common. Unfortunately these mechanism tend to interfere. If this happens, one can temporarily disable all add-ons/extensions, to find out if one of them is responsible for the problem. If the problem disappears, one can enable the suspicios ones one-by-one to find the culprit.

In my case, I am making use of a browser add-on called "Cookie AutoDelete". This add-on deletes all cookies when completely closing the browser, which of course was the problem.

The remedy is to make a white list entry for askubuntu.com in the preferences of the add-on. In my case, the corresponding entries for *.stackexchange.com were already there. I had created them earlier and forgot about it. Thanks @ByteCommander to hint me in the right direction.

0

One reason, is because we have a unique login, that is, via launchpad:

enter image description here

As far as I know, you can't login to any other SE with Launchpad.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .