I have seen questions popping up on this site where people have been installing the ukuu (Ubuntu Kernel Update Utility) that will allow for them to install the latest (Mainline) kernels into their setup. My question is, since these will be kernels that have not been tested nor are they part of the release schedule, will this be supported as on topic here?

I am asking this because these kernels are part of unsupported versions of Ubuntu that are either EOL or that they have not been officially released yet and we don't support those versions of Ubuntu.

up vote 13 down vote accepted

A critical difference between an "unsupported" kernel and (eg) Mint is —if the kernel might be even-slightly-relevant— we can just ask...

Do you have the same problem with the stock kernel?

It's quick to test. And most Ukuu users seem to have the stock ones installed still.

The differences between distributions are much larger.

I wouldn't get too hung up on the "tested" factor. There are near infinite combinations of software within Ubuntu. A fraction of a percent of those are actually tested. We don't only support those.

  • This works for me. There was one where they were trying to get the NVIDIA drivers installed, but they would not work with the 4.17 kernel that they installed on their system. Hence, this is the reason why I asked. I won't get hung up on the tested factor. I guess the good thing about this site is it is 100% voluntary and if we don't want to answer it, then we don't have to. Thank you for your input! =) – Terrance Jul 22 at 16:00
  • 2
    I mean that's an example where you get a useful Q&A that can be used to dupe-close future "I'm using a bleeding edge kernel, why won't Nvidia's DKMS compile?" questions against. Nivida is notorious for not quite keeping up with releases, and usually never RCs. – Oli Jul 22 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .