Should be in META, but I can't post there without logging in:I am unable to login using the Launchpad OpenID. When I click the launchpad button the page stays the same. (It has links to recover my account or make a new one, but no input boxes.) This has worked for me before with firefox4. It also does not work with Chromium. I'm not sure what has changed. What can I do to login? I'm using firefox 4. I don't have the noscript plugin installed.

  • To help narrow the cause of the login issue, has the Launchpad OpenID ever worked for you while using Firefox 4? Have you tried another web browser (e.g., Chromium)?
    – Kory Wnuk
    Commented Jun 22, 2011 at 0:36
  • @Kory I have updated my question to address the questions you asked.
    – user20418
    Commented Jun 22, 2011 at 1:20
  • 1
    Possible Duplicate Commented Jun 22, 2011 at 2:22
  • @Marco Ceppi Yes, it sounds the same, but it has the status-completed tag. Does that mean it should be fixed but it's not?
    – Azendale
    Commented Jun 22, 2011 at 4:01

1 Answer 1


Here's how I finally got in to my account: Clear the cache and cookies in your browser. Then go to the login page and click the more OpenID options link. Put in https://launchpad.net/~<your-launchpad-user-name> and click sign in.

  • Also remember, when you clear your cache and cookies, to specify the correct "Time range to clear:".
    – Geoffrey
    Commented Aug 22, 2012 at 14:14

You must log in to answer this question.