The current notification sound is a little bit annoying. I thought the sound is the browser default sound but it is not. I heard a different sound the same browser in different chat rooms.

How can i change notification sound?

share

migrated from askubuntu.com Jul 3 '11 at 11:24

This question came from our site for Ubuntu users and developers.

1  
This is a meta question –  Alvar Jul 3 '11 at 11:04
    
@Alvar: It's not a meta question. A meta question is about the site itself, this question is about Ubuntu itself: changing the notify-osd sound, which does not have to be related to AU. –  Lekensteyn Jul 3 '11 at 11:15
    
please explain yourself more Achu so we understand. IS it specific to AU or is it general for the browser? –  Alvar Jul 3 '11 at 11:17
    
@Alvar meta? how is this meta?... @Achu you need to change the Sound theme on Sound preferences. –  Uri Herrera Jul 3 '11 at 11:17
    
join the chat... I think it's a meta..... –  Alvar Jul 3 '11 at 11:23
add comment

2 Answers 2

up vote 10 down vote accepted

I've created an Userscript for it which is available at SE Chat custom notification sound.

After installation, you need to reload the page. The button will be available next to the "set audio notification level" button:

Screenshot

share
1  
Good job! it is Awesome!.... –  Achu Jul 4 '11 at 18:50
    
victorychat.org/message_for_me ← this does't work (it's audio/x-wav). Any chance you can make this work? –  Stefano Palazzo Jul 5 '11 at 8:30
    
You need to convert it to a MP3 file, it's stated explicitly in the description. I might make an upload feature that does that automatically, but I've yet some work to do like a backup plan that should have been completed two months ago :O –  Lekensteyn Jul 5 '11 at 11:27
add comment

You can't.

The SE Chat creates an audio element on the site to play the sound (or a Flash applet, if your browser doesn't support it). So the sound is hard coded into the system.

The only thing you can do is disable the sound altogether. Luckily, this is pretty granular:

enter image description here

share
1  
You can't yet... –  Alvar Jul 3 '11 at 12:00
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .